aboutsummaryrefslogtreecommitdiffstats
path: root/icepll
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2016-03-02 12:34:51 +0100
committerClifford Wolf <clifford@clifford.at>2016-03-02 12:34:51 +0100
commit6178dfbbd612d15a46c7d2a439b2252d6d0a87ba (patch)
tree0abe2fef49ac4585cc3d0f43d88e6ca9be3bea7d /icepll
parent0ac6a3545a17b860ed5a5bf6fcc8303418b25e5a (diff)
downloadicestorm-6178dfbbd612d15a46c7d2a439b2252d6d0a87ba.tar.gz
icestorm-6178dfbbd612d15a46c7d2a439b2252d6d0a87ba.tar.bz2
icestorm-6178dfbbd612d15a46c7d2a439b2252d6d0a87ba.zip
Added Makefile support for "make STATIC=1"
Diffstat (limited to 'icepll')
-rw-r--r--icepll/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/icepll/Makefile b/icepll/Makefile
index b47de3e..e0badf6 100644
--- a/icepll/Makefile
+++ b/icepll/Makefile
@@ -2,6 +2,10 @@ include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
+ifeq ($(STATIC),1)
+LDFLAGS += -static
+endif
+
all: icepll$(EXE)
icepll$(EXE): icepll.o