aboutsummaryrefslogtreecommitdiffstats
path: root/icetime
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2016-01-01 15:08:41 +0100
committerClifford Wolf <clifford@clifford.at>2016-01-01 15:08:41 +0100
commit804e47d8ff5651b579f6c43fcb96b569e0cbcdc5 (patch)
tree797ba1afb5713951983b937133dd7ad5128f5ab8 /icetime
parented545ce4ce569bb96b2cba017daf2731afdaa926 (diff)
downloadicestorm-804e47d8ff5651b579f6c43fcb96b569e0cbcdc5.tar.gz
icestorm-804e47d8ff5651b579f6c43fcb96b569e0cbcdc5.tar.bz2
icestorm-804e47d8ff5651b579f6c43fcb96b569e0cbcdc5.zip
Renamed IceBox .txt files to .asc files
Diffstat (limited to 'icetime')
-rw-r--r--icetime/Makefile4
-rw-r--r--icetime/icetime.cc4
-rw-r--r--icetime/show.sh2
3 files changed, 5 insertions, 5 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index c98f40b..7edfc6c 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -20,11 +20,11 @@ uninstall:
test0 test1 test2 test3 test4 test5 test6 test7 test8 test9: icetime
test -f $@_ref.v || python3 mktest.py $@
- ./icetime -P tq144 -p $@.pcf $@.txt $@_out.v
+ ./icetime -P tq144 -p $@.pcf $@.asc $@_out.v
yosys $@.ys
run0 run1 run2 run3 run4 run5 run6 run7 run8 run9: icetime
- ./icetime -P tq144 -p $(subst run,test,$@).pcf $(subst run,test,$@).txt $(subst run,test,$@)_out.v
+ ./icetime -P tq144 -p $(subst run,test,$@).pcf $(subst run,test,$@).asc $(subst run,test,$@)_out.v
show0 show1 show2 show3 show4 show5 show6 show7 show8 show9: icetime
bash show.sh $(subst show,test,$@)
diff --git a/icetime/icetime.cc b/icetime/icetime.cc
index 0a76836..b4abbd6 100644
--- a/icetime/icetime.cc
+++ b/icetime/icetime.cc
@@ -1137,7 +1137,7 @@ void make_interconn(const net_segment_t &src, FILE *graph_f)
void help(const char *cmd)
{
printf("\n");
- printf("Usage: %s [options] input.txt [output.v]\n", cmd);
+ printf("Usage: %s [options] input.asc [output.v]\n", cmd);
printf("\n");
printf(" -p <pcf_file>\n");
printf(" -P <chip_package>\n");
@@ -1194,7 +1194,7 @@ int main(int argc, char **argv)
} else
help(argv[0]);
- printf("// Reading input .txt file..\n");
+ printf("// Reading input .asc file..\n");
read_config();
printf("// Reading chipdb file..\n");
diff --git a/icetime/show.sh b/icetime/show.sh
index ee3e7bd..4e7eb04 100644
--- a/icetime/show.sh
+++ b/icetime/show.sh
@@ -9,7 +9,7 @@ yosys -p '
show -prefix equiv_graph -format dot a:equiv_region!=0 %co2 a:equiv_region!=0 %ci2
' $1.il
-./icetime -P tq144 -p $1.pcf $1.txt $( sed 's,_gate$,,; s,.*_,-g ,;' < equiv_graph.segs ) > /dev/null
+./icetime -P tq144 -p $1.pcf $1.asc $( sed 's,_gate$,,; s,.*_,-g ,;' < equiv_graph.segs ) > /dev/null
{
egrep -v '^}' icetime_graph.dot