aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5e23184..8c2bfd5 100644
--- a/Makefile
+++ b/Makefile
@@ -32,5 +32,12 @@ uninstall:
$(MAKE) -C icepll uninstall
$(MAKE) -C icetime uninstall
+mxebin: clean
+ $(MAKE) MXE=1
+ rm -rf icestorm-win32 && mkdir icestorm-win32
+ cp icebox/chipdb-*.txt icepack/*.exe iceprog/*.exe icestorm-win32/
+ cp icemulti/*.exe icepll/*.exe icetime/*.exe icestorm-win32/
+ zip -r icestorm-win32.zip icestorm-win32/
+
.PHONY: all clean install uninstall