aboutsummaryrefslogtreecommitdiffstats
path: root/examples/hx8kboard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/hx8kboard/Makefile')
-rw-r--r--examples/hx8kboard/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/examples/hx8kboard/Makefile b/examples/hx8kboard/Makefile
index bcecdf2..eea99c4 100644
--- a/examples/hx8kboard/Makefile
+++ b/examples/hx8kboard/Makefile
@@ -1,14 +1,15 @@
PROJ = example
PIN_DEF = hx8kboard.pcf
DEVICE = hx8k
+PACKAGE = ct256
all: $(PROJ).rpt $(PROJ).bin
-%.blif: %.v
- yosys -p 'synth_ice40 -top top -blif $@' $<
+%.json: %.v
+ yosys -p 'synth_ice40 -top top -json $@' $<
-%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^
+%.asc: $(PIN_DEF) %.json
+ nextpnr-ice40 --$(DEVICE) --package $(PACKAGE) --asc $@ --pcf $< --json $*.json
%.bin: %.asc
icepack $< $@
@@ -24,7 +25,7 @@ sudo-prog: $(PROJ).bin
sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+ rm -f $(PROJ).json $(PROJ).asc $(PROJ).rpt $(PROJ).bin
.SECONDARY:
.PHONY: all prog clean