aboutsummaryrefslogtreecommitdiffstats
path: root/examples/iceblink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/iceblink/Makefile')
-rw-r--r--examples/iceblink/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/examples/iceblink/Makefile b/examples/iceblink/Makefile
index 8f908a8..25ffe3c 100644
--- a/examples/iceblink/Makefile
+++ b/examples/iceblink/Makefile
@@ -1,18 +1,21 @@
PROJ = example
PIN_DEF = iceblink.pcf
-DEVICE = 1k
+DEVICE = hx1k
-all: $(PROJ).bin
+all: $(PROJ).rpt $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
%.asc: $(PIN_DEF) %.blif
- arachne-pnr -d $(DEVICE) -o $@ -p $^ -P vq100
+ arachne-pnr -d $(subst hx,,$(subst lp,,$(DEVICE))) -o $@ -p $^ -P vq100
%.bin: %.asc
icepack $< $@
+%.rpt: %.asc
+ icetime -d $(DEVICE) -mtr $@ $<
+
prog: $(PROJ).bin
iCEburn.py -e -v -w $<