aboutsummaryrefslogtreecommitdiffstats
path: root/examples/icemulti/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/icemulti/Makefile')
-rw-r--r--examples/icemulti/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/icemulti/Makefile b/examples/icemulti/Makefile
index d8a8320..a7ce692 100644
--- a/examples/icemulti/Makefile
+++ b/examples/icemulti/Makefile
@@ -9,12 +9,12 @@ config.bin: app0.bin app1.bin app2.bin app3.bin
icemulti -v -A16 -p0 -o config.bin app0.bin app1.bin app2.bin app3.bin
app%.bin: app%.v icestick.pcf
- yosys -p "synth_ice40 -top top -blif $(basename $<).blif" $<
- arachne-pnr -o $(basename $<).asc -d 1k -P tq144 -p icestick.pcf $(basename $<).blif
+ yosys -p "synth_ice40 -top top -json $(basename $<).json" $<
+ nextpnr-ice40 --hx1k --package tq144 --asc $(basename $<).asc --pcf icestick.pcf --json $(basename $<).json
icetime -d hx1k -c 25 $(basename $<).asc
icepack $(basename $<).asc $(basename $<).bin
clean:
- rm -f app?.asc app?.bin app?.blif config.bin
+ rm -f app?.asc app?.bin app?.json config.bin
.PHONY: prog sudo-prog clean