aboutsummaryrefslogtreecommitdiffstats
path: root/examples/icestick/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/icestick/Makefile')
-rw-r--r--examples/icestick/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/examples/icestick/Makefile b/examples/icestick/Makefile
index 06a5633..26b79f8 100644
--- a/examples/icestick/Makefile
+++ b/examples/icestick/Makefile
@@ -2,7 +2,7 @@ PROJ = example
PIN_DEF = icestick.pcf
DEVICE = 1k
-all: $(PROJ).bin
+all: $(PROJ).rpt $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
@@ -13,14 +13,18 @@ all: $(PROJ).bin
%.bin: %.asc
icepack $< $@
+%.rpt: %.asc
+ icetime -mt $< | tee $@
+
prog: $(PROJ).bin
iceprog $<
sudo-prog: $(PROJ).bin
@echo 'Executing prog as root!!!'
- iceprog $<
+ sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).bin
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+.SECONDARY:
.PHONY: all prog clean