aboutsummaryrefslogtreecommitdiffstats
path: root/examples/up5k
diff options
context:
space:
mode:
Diffstat (limited to 'examples/up5k')
-rw-r--r--examples/up5k/.gitignore4
-rw-r--r--examples/up5k/Makefile36
-rw-r--r--examples/up5k/example.v10
-rw-r--r--examples/up5k/up5k.pcf3
4 files changed, 0 insertions, 53 deletions
diff --git a/examples/up5k/.gitignore b/examples/up5k/.gitignore
deleted file mode 100644
index c1fa30b..0000000
--- a/examples/up5k/.gitignore
+++ /dev/null
@@ -1,4 +0,0 @@
-example.bin
-example.blif
-example.asc
-example.rpt
diff --git a/examples/up5k/Makefile b/examples/up5k/Makefile
deleted file mode 100644
index ea16f06..0000000
--- a/examples/up5k/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-PROJ = example
-PIN_DEF = up5k.pcf
-DEVICE = up5k
-# Relative paths for easier development without messing with installed version
-ARACHNE = ../../../arachne-pnr/bin/arachne-pnr
-ARACHNE_ARGS = -c ../../icebox/chipdb-5k.txt
-ICEPACK = ../../icepack/icepack
-ICETIME = ../../icetime/icetime
-ICEPROG = ../../iceprog/iceprog
-
-all: $(PROJ).bin
-
-%.blif: %.v
- yosys -p 'synth_ice40 -top top -blif $@' $<
-
-%.asc: $(PIN_DEF) %.blif
- $(ARACHNE) $(ARACHNE_ARGS) -d $(subst up,,$(subst hx,,$(subst lp,,$(DEVICE)))) -o $@ -p $^
-
-%.bin: %.asc
- $(ICEPACK) $< $@
-
-%.rpt: %.asc
- $(ICETIME) -d $(DEVICE) -mtr $@ $<
-
-prog: $(PROJ).bin
- $(ICEPROG) -S $<
-
-sudo-prog: $(PROJ).bin
- @echo 'Executing prog as root!!!'
- sudo $(ICEPROG) -S $<
-
-clean:
- rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
-
-.SECONDARY:
-.PHONY: all prog clean
diff --git a/examples/up5k/example.v b/examples/up5k/example.v
deleted file mode 100644
index 01b76b8..0000000
--- a/examples/up5k/example.v
+++ /dev/null
@@ -1,10 +0,0 @@
-module top (
- input btn,
- output LED0,
- output LED1,
-);
-
-assign LED0 = !btn;
-assign LED1 = btn;
-
-endmodule
diff --git a/examples/up5k/up5k.pcf b/examples/up5k/up5k.pcf
deleted file mode 100644
index b1d1263..0000000
--- a/examples/up5k/up5k.pcf
+++ /dev/null
@@ -1,3 +0,0 @@
-set_io LED0 12
-set_io LED1 21
-set_io btn 26