aboutsummaryrefslogtreecommitdiffstats
path: root/examples/up5k_mac16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'examples/up5k_mac16/Makefile')
-rw-r--r--examples/up5k_mac16/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/examples/up5k_mac16/Makefile b/examples/up5k_mac16/Makefile
new file mode 100644
index 0000000..06c9ed7
--- /dev/null
+++ b/examples/up5k_mac16/Makefile
@@ -0,0 +1,36 @@
+PROJ = mac16
+PIN_DEF = mac16.pcf
+DEVICE = up5k
+
+ARACHNE = arachne-pnr
+ARACHNE_ARGS =
+ICEPACK = icepack
+ICETIME = icetime
+ICEPROG = iceprog
+
+all: $(PROJ).bin
+
+%.blif: %.v
+ yosys -p 'synth_ice40 -top top -blif $@' $<
+
+%.asc: $(PIN_DEF) %.blif
+ $(ARACHNE) $(ARACHNE_ARGS) -d $(subst up,,$(subst hx,,$(subst lp,,$(DEVICE)))) -o $@ -p $^
+
+%.bin: %.asc
+ $(ICEPACK) $< $@
+
+%.rpt: %.asc
+ $(ICETIME) -d $(DEVICE) -mtr $@ $<
+
+prog: $(PROJ).bin
+ $(ICEPROG) -S $<
+
+sudo-prog: $(PROJ).bin
+ @echo 'Executing prog as root!!!'
+ sudo $(ICEPROG) -S $<
+
+clean:
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).rpt $(PROJ).bin
+
+.SECONDARY:
+.PHONY: all prog clean