aboutsummaryrefslogtreecommitdiffstats
path: root/examples
diff options
context:
space:
mode:
Diffstat (limited to 'examples')
-rw-r--r--examples/hx8kboard/Makefile6
-rw-r--r--examples/icestick/Makefile6
2 files changed, 6 insertions, 6 deletions
diff --git a/examples/hx8kboard/Makefile b/examples/hx8kboard/Makefile
index e9fd789..9795cdf 100644
--- a/examples/hx8kboard/Makefile
+++ b/examples/hx8kboard/Makefile
@@ -7,10 +7,10 @@ all: $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
-%.txt: $(PIN_DEF) %.blif
+%.asc: $(PIN_DEF) %.blif
arachne-pnr -d $(DEVICE) -o $@ -p $^
-%.bin: %.txt
+%.bin: %.asc
icepack $< $@
prog: $(PROJ).bin
@@ -21,6 +21,6 @@ sudo-prog: $(PROJ).bin
sudo iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).txt $(PROJ).bin
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).bin
.PHONY: all prog clean
diff --git a/examples/icestick/Makefile b/examples/icestick/Makefile
index eaed6f7..06a5633 100644
--- a/examples/icestick/Makefile
+++ b/examples/icestick/Makefile
@@ -7,10 +7,10 @@ all: $(PROJ).bin
%.blif: %.v
yosys -p 'synth_ice40 -top top -blif $@' $<
-%.txt: $(PIN_DEF) %.blif
+%.asc: $(PIN_DEF) %.blif
arachne-pnr -d $(DEVICE) -o $@ -p $^
-%.bin: %.txt
+%.bin: %.asc
icepack $< $@
prog: $(PROJ).bin
@@ -21,6 +21,6 @@ sudo-prog: $(PROJ).bin
iceprog $<
clean:
- rm -f $(PROJ).blif $(PROJ).txt $(PROJ).bin
+ rm -f $(PROJ).blif $(PROJ).asc $(PROJ).bin
.PHONY: all prog clean