aboutsummaryrefslogtreecommitdiffstats
path: root/icebram/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icebram/Makefile')
-rw-r--r--icebram/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/icebram/Makefile b/icebram/Makefile
new file mode 100644
index 0000000..827fe7c
--- /dev/null
+++ b/icebram/Makefile
@@ -0,0 +1,33 @@
+include ../config.mk
+LDLIBS = -lm -lstdc++
+CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include
+
+ifeq ($(STATIC),1)
+LDFLAGS += -static
+endif
+
+all: icebram$(EXE)
+
+icebram$(EXE): icebram.o
+ $(CC) -o $@ $(LDFLAGS) $^ $(LDLIBS)
+
+test: icebram
+ bash rundemo.sh
+
+install: all
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ cp icebram $(DESTDIR)$(PREFIX)/bin/icebram
+
+uninstall:
+ rm -f $(DESTDIR)$(PREFIX)/bin/icebram
+
+clean:
+ rm -f icebram
+ rm -f icebram.exe
+ rm -f demo.* demo_*.*
+ rm -f *.o *.d
+
+-include *.d
+
+.PHONY: all test install uninstall clean
+