aboutsummaryrefslogtreecommitdiffstats
path: root/icecompr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icecompr/Makefile')
-rw-r--r--icecompr/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/icecompr/Makefile b/icecompr/Makefile
new file mode 100644
index 0000000..88512f0
--- /dev/null
+++ b/icecompr/Makefile
@@ -0,0 +1,31 @@
+
+all: icecompr iceuncompr
+
+test: example_1k.ok example_8k.ok
+
+icecompr: icecompr.cc
+ clang++ -o icecompr -Wall -Wextra -std=c++11 icecompr.cc
+
+iceuncompr: iceuncompr.c
+ clang -o iceuncompr -Wall -Wextra iceuncompr.c
+
+%.compr: %.bin icecompr
+ ./icecompr -v $< $@
+
+
+%.uncompr: %.compr iceuncompr
+ ./iceuncompr $< $@
+
+%.ok: %.uncompr %.bin
+ cmp $^
+ touch $@
+
+clean:
+ rm -f icecompr iceuncompr
+ rm -f example_1k.compr example_8k.compr
+ rm -f example_1k.uncompr example_8k.uncompr
+ rm -f example_1k.ok example_8k.ok
+
+.SECONDARY:
+.PHONY: all test clean
+