aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/fuzzconfig.py
diff options
context:
space:
mode:
Diffstat (limited to 'icefuzz/fuzzconfig.py')
-rw-r--r--icefuzz/fuzzconfig.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/icefuzz/fuzzconfig.py b/icefuzz/fuzzconfig.py
index f03c815..f48d2d0 100644
--- a/icefuzz/fuzzconfig.py
+++ b/icefuzz/fuzzconfig.py
@@ -97,6 +97,26 @@ elif device_class == "5k":
#TODO(tannewt): Add 39, 40, 41 to this list. It causes placement failures for some reason.
gpins = "20 35 37 44".split()
led_pins = "39 40 41".split()
+
+elif device_class == "u4k":
+ num_ramb40 = 20
+ num_iobanks = 2
+ num_dsp = 4
+
+ #TODO(tannewt): Add 39, 40, 41 to this list. It causes placement failures for some reason.
+ # Also add 14 15 16 17 which are constrained to SPI.
+ #TODO(daveshah1): Add back I3C IO 23 which cause placement failures when assigned to
+ #an SB_IO clk_in
+ pins = """2 3 4 6 9 10 11 12
+ 13 18 19 20 21
+ 25 26 27 28 31 32 34 35 36
+ 37 38 42 43 44 45 46 47 48
+ """.split()
+
+ #TODO(tannewt): Add 39, 40, 41 to this list. It causes placement failures for some reason.
+ gpins = "20 35 37 44".split()
+ led_pins = "39 40 41".split()
+
def output_makefile(working_dir, fuzzname):
with open(working_dir + "/Makefile", "w") as f:
print("all: %s" % " ".join(["%s_%02d.bin" % (fuzzname, i) for i in range(num)]), file=f)