aboutsummaryrefslogtreecommitdiffstats
path: root/icefuzz/make_mem.py
diff options
context:
space:
mode:
Diffstat (limited to 'icefuzz/make_mem.py')
-rw-r--r--icefuzz/make_mem.py19
1 files changed, 10 insertions, 9 deletions
diff --git a/icefuzz/make_mem.py b/icefuzz/make_mem.py
index ab38849..0fe5aa4 100644
--- a/icefuzz/make_mem.py
+++ b/icefuzz/make_mem.py
@@ -4,11 +4,15 @@ from fuzzconfig import *
import numpy as np
import os
-os.system("rm -rf work_mem")
-os.mkdir("work_mem")
+device_class = os.getenv("ICEDEVICE")
+
+working_dir = "work_%s_mem" % (device_class, )
+
+os.system("rm -rf " + working_dir)
+os.mkdir(working_dir)
for idx in range(num):
- with open("work_mem/mem_%02d.v" % idx, "w") as f:
+ with open(working_dir + "/mem_%02d.v" % idx, "w") as f:
print("""
module top(input clk, i0, i1, i2, i3, output reg o0, o1, o2, o3, o4);
reg [9:0] raddr, waddr, rdata, wdata;
@@ -27,14 +31,11 @@ for idx in range(num):
end
endmodule
""", file=f)
- with open("work_mem/mem_%02d.pcf" % idx, "w") as f:
+ with open(working_dir + "/mem_%02d.pcf" % idx, "w") as f:
p = list(np.random.permutation(pins))
for port in [ "clk", "i0", "i1", "i2", "i3", "o0", "o1", "o2", "o3", "o4" ]:
print("set_io %s %s" % (port, p.pop()), file=f)
-with open("work_mem/Makefile", "w") as f:
- print("all: %s" % " ".join(["mem_%02d.bin" % i for i in range(num)]), file=f)
- for i in range(num):
- print("mem_%02d.bin:" % i, file=f)
- print("\t-bash ../icecube.sh mem_%02d > mem_%02d.log 2>&1 && rm -rf mem_%02d.tmp || tail mem_%02d.log" % (i, i, i, i), file=f)
+
+output_makefile(working_dir, "mem")