aboutsummaryrefslogtreecommitdiffstats
path: root/icemulti/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icemulti/Makefile')
-rw-r--r--icemulti/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/icemulti/Makefile b/icemulti/Makefile
index 387549d..c901413 100644
--- a/icemulti/Makefile
+++ b/icemulti/Makefile
@@ -2,9 +2,10 @@ include ../config.mk
LDLIBS = -lm -lstdc++
CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11
-all: icemulti
+all: icemulti$(EXE)
-icemulti: icemulti.o
+icemulti$(EXE): icemulti.o
+ $(CC) -o $@ $(LDFLAGS) $^ $(LDLIBS)
install: all
mkdir -p $(DESTDIR)$(PREFIX)/bin
@@ -15,6 +16,7 @@ uninstall:
clean:
rm -f icemulti
+ rm -f icemulti.exe
rm -f *.o *.d
-include *.d