aboutsummaryrefslogtreecommitdiffstats
path: root/icetime/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'icetime/Makefile')
-rw-r--r--icetime/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/icetime/Makefile b/icetime/Makefile
index cfa7ff0..f30a42a 100644
--- a/icetime/Makefile
+++ b/icetime/Makefile
@@ -1,6 +1,6 @@
include ../config.mk
LDLIBS = -lm -lstdc++
-CXXFLAGS = -MD -O0 -ggdb -Wall -std=c++11 -I/usr/local/include -DPREFIX='"$(PREFIX)"' -DCHIPDB_SUBDIR='"$(CHIPDB_SUBDIR)"'
+override CXXFLAGS += -DPREFIX='"$(PREFIX)"' -DCHIPDB_SUBDIR='"$(CHIPDB_SUBDIR)"'
ifeq ($(STATIC),1)
LDFLAGS += -static
@@ -9,7 +9,7 @@ endif
all: icetime$(EXE)
icetime$(EXE): icetime.o
- $(CC) -o $@ $(LDFLAGS) $^ $(LDLIBS)
+ $(CXX) -o $@ $(LDFLAGS) $^ $(LDLIBS)
icetime.o: icetime.cc timings.inc