aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-06-01 21:03:33 +0100
committergatecat <gatecat@ds0.me>2021-06-01 21:03:33 +0100
commit5921a5b6204d04d21961e99dfa70bd919f686164 (patch)
treed78d24b33bc6f831b978f37b880cba9e2b9cc898
parentcaf7261be7b34b365ab6d8449455891c2ed28faa (diff)
downloadnextpnr-tests-5921a5b6204d04d21961e99dfa70bd919f686164.tar.gz
nextpnr-tests-5921a5b6204d04d21961e99dfa70bd919f686164.tar.bz2
nextpnr-tests-5921a5b6204d04d21961e99dfa70bd919f686164.zip
Allow gzip to overwrite
Signed-off-by: gatecat <gatecat@ds0.me>
-rw-r--r--ice40/regressions/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/ice40/regressions/Makefile b/ice40/regressions/Makefile
index 2e961fe..8793053 100644
--- a/ice40/regressions/Makefile
+++ b/ice40/regressions/Makefile
@@ -20,7 +20,7 @@ ifeq ($(wildcard $(NPNR)),)
endif
%.json: %.json.gz
- gzip -dk $<
+ gzip -fdk $<
$(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
$(NPNR) --json $*.json --asc $*.asc $(if $(wildcard $*.pcf),--pcf $*.pcf,) $(if $(wildcard $*.npnr),$(shell cat $*.npnr),) > /dev/null 2>&1 || test -f $(dir $*)WAIVE
@@ -31,7 +31,7 @@ $(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
fi
$(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
- gzip -dk $*.json.gz
+ gzip -fdk $*.json.gz
cd $(dir $@) && NPNR=$(NPNR) bash $(notdir $*.sh) > /dev/null 2>&1
if [ -f "$*.asc" ]; then \
icebox_vlog $*.asc > $@; \