aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEddie Hung <eddieh@ece.ubc.ca>2019-02-12 17:02:11 -0800
committerEddie Hung <eddieh@ece.ubc.ca>2019-02-12 17:02:11 -0800
commit7678a5904b06d8eb23165058a1b0a753ae0ed02e (patch)
treeb613c9c03a7f4918aacfc42ce10ae853edbd501b
parent49e8246fd0b76023605d98039118e3fcbbcabb1b (diff)
downloadnextpnr-tests-7678a5904b06d8eb23165058a1b0a753ae0ed02e.tar.gz
nextpnr-tests-7678a5904b06d8eb23165058a1b0a753ae0ed02e.tar.bz2
nextpnr-tests-7678a5904b06d8eb23165058a1b0a753ae0ed02e.zip
Decompress *.json.gz
-rw-r--r--ice40/regressions/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/ice40/regressions/Makefile b/ice40/regressions/Makefile
index 241b41c..00243f8 100644
--- a/ice40/regressions/Makefile
+++ b/ice40/regressions/Makefile
@@ -19,7 +19,7 @@ ifeq ($(wildcard $(NPNR)),)
$(error "$$(NPNR) must point to a nextpnr-ice40 binary (currently: $@)")
endif
-%: %.gz
+%.json: %.json.gz
gzip -dk $<
$(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
@@ -27,6 +27,7 @@ $(JSON_OUTPUT): %_postpnr.v: %.json $(wildcard %.pcf) $(wildcard %.npnr) $(NPNR)
icebox_vlog $*.asc > $@
$(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
+ gzip -dk $*.json.gz
cd $(dir $@) && NPNR=$(NPNR) bash $(notdir $*.sh) > /dev/null 2>&1
if [ -f "$*.asc" ]; then \
icebox_vlog $*.asc > $@; \
@@ -35,4 +36,4 @@ $(SH_OUTPUT): %_postpnr.v: %.sh $(NPNR)
fi
clean:
- @rm -f */*.asc $(JSON_OUTPUT) $(SH_OUTPUT)
+ @rm -f */*.asc $(JSON) $(JSON_OUTPUT) $(SH_OUTPUT)