aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-20 14:24:16 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-20 16:15:33 +0200
commite14b8bac66bf9a65ddd709fba53aac017691f0c8 (patch)
treeb036a37e1dba0bdf07e19baa40d7a611ff6fbf59 /3rdparty/QtPropertyBrowser/src/CMakeLists.txt
parente45508f6c41273830312a5b88c5e25f266dc67ae (diff)
downloadnextpnr-e14b8bac66bf9a65ddd709fba53aac017691f0c8.tar.gz
nextpnr-e14b8bac66bf9a65ddd709fba53aac017691f0c8.tar.bz2
nextpnr-e14b8bac66bf9a65ddd709fba53aac017691f0c8.zip
put source changes for qtpropertybrowser back and make build simple
Diffstat (limited to '3rdparty/QtPropertyBrowser/src/CMakeLists.txt')
-rw-r--r--3rdparty/QtPropertyBrowser/src/CMakeLists.txt28
1 files changed, 1 insertions, 27 deletions
diff --git a/3rdparty/QtPropertyBrowser/src/CMakeLists.txt b/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
index ac70956d..abee16a1 100644
--- a/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
+++ b/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
@@ -16,9 +16,6 @@ set(_SRCS
qtvariantproperty.cpp
)
-file(GLOB _IMPL_HDRS *.h)
-file(GLOB _PUBLIC_HDRS Qt*)
-
set(_UI_FORMS
)
@@ -31,7 +28,7 @@ QT5_ADD_RESOURCES(_QRC_SRCS ${_RESOURCES})
set(TARGET_NAME ${PROJECT_NAME})
-add_library(${TARGET_NAME}
+add_library(${TARGET_NAME} STATIC
${_SRCS}
${_UI_SRCS}
${_QRC_SRCS}
@@ -39,26 +36,3 @@ add_library(${TARGET_NAME}
)
target_link_libraries(${TARGET_NAME} Qt5::Widgets)
-
-######################### Installation Stuff ###########################
-include(GenerateExportHeader)
-generate_export_header(${TARGET_NAME})
-
-install(TARGETS ${TARGET_NAME}
- EXPORT ${TARGET_NAME}Targets
- RUNTIME DESTINATION ${INSTALL_BIN_DIR}
- LIBRARY DESTINATION ${INSTALL_LIB_DIR}
- ARCHIVE DESTINATION ${INSTALL_LIB_DIR}
- INCLUDES DESTINATION ${INSTALL_INCLUDE_DIR}
-)
-
-install(
- FILES
- ${_PUBLIC_HDRS}
- ${_IMPL_HDRS}
- DESTINATION
- ${INSTALL_INCLUDE_DIR}
- COMPONENT
- Devel
-)
-