aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/python-console/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-28 13:26:07 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-28 17:57:26 +0200
commit9347c8742d8faf8b39fea4cbbe13b7a1d2440c18 (patch)
tree28507cda091461779142b54c60f9577e3c911833 /3rdparty/python-console/CMakeLists.txt
parentc63274342f1aaa3d1087c0df5ffdaccfd0afcd56 (diff)
downloadnextpnr-9347c8742d8faf8b39fea4cbbe13b7a1d2440c18.tar.gz
nextpnr-9347c8742d8faf8b39fea4cbbe13b7a1d2440c18.tar.bz2
nextpnr-9347c8742d8faf8b39fea4cbbe13b7a1d2440c18.zip
make it compile with qt5
Diffstat (limited to '3rdparty/python-console/CMakeLists.txt')
-rw-r--r--3rdparty/python-console/CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/3rdparty/python-console/CMakeLists.txt b/3rdparty/python-console/CMakeLists.txt
index dd4d6047..89433edc 100644
--- a/3rdparty/python-console/CMakeLists.txt
+++ b/3rdparty/python-console/CMakeLists.txt
@@ -1,15 +1,16 @@
cmake_minimum_required( VERSION 2.8 )
project( PythonInterpreter )
-find_package( Qt4 REQUIRED )
-include( ${QT_USE_FILE} )
+set(CMAKE_CXX_STANDARD 11)
+find_package(Qt5 COMPONENTS Core Widgets REQUIRED)
+
find_package( PythonLibs REQUIRED )
include_directories( ${PYTHON_INCLUDE_DIRS} )
add_executable( test_python_interpreter test_python_interpreter.cpp Interpreter.cpp )
target_link_libraries( test_python_interpreter ${PYTHON_LIBRARIES} )
-qt4_wrap_cpp( Console_MOC Console.h )
+qt5_wrap_cpp( Console_MOC Console.h )
add_executable( test_console test_console.cpp
Console.cpp ${Console_MOC}
ColumnFormatter.cpp
@@ -20,11 +21,13 @@ add_executable( test_console test_console.cpp
ParseHelper.ContinuationParseState.cpp
ParseMessage.cpp
)
-target_link_libraries( test_console ${QT_LIBRARIES} ${PYTHON_LIBRARIES} )
+target_compile_definitions( test_console PRIVATE QT_NO_KEYWORDS)
+target_link_libraries( test_console Qt5::Widgets ${PYTHON_LIBRARIES} )
add_executable( test_parse_helper test_parse_helper.cpp
ParseHelper.cpp
ParseHelper.BlockParseState.cpp
+ ParseHelper.BracketParseState.cpp
ParseHelper.ContinuationParseState.cpp
ParseListener.cpp
ParseMessage.cpp
@@ -33,6 +36,7 @@ add_executable( test_parse_helper test_parse_helper.cpp
add_executable( test_cli test_cli.cpp
ParseHelper.cpp
ParseHelper.BlockParseState.cpp
+ ParseHelper.BracketParseState.cpp
ParseHelper.ContinuationParseState.cpp
ParseListener.cpp
ParseMessage.cpp