aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty/sanitizers-cmake/tests
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-24 19:05:53 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-24 19:05:53 +0200
commitbf2c0af0eab82138fe32e1f42cc8f3903fea2790 (patch)
tree86a968fe59287d50df5ae6b4a7f35b10dc4c929e /3rdparty/sanitizers-cmake/tests
parent1acaf4127745354e83fb230bd3f965c562bb2f9b (diff)
downloadnextpnr-bf2c0af0eab82138fe32e1f42cc8f3903fea2790.tar.gz
nextpnr-bf2c0af0eab82138fe32e1f42cc8f3903fea2790.tar.bz2
nextpnr-bf2c0af0eab82138fe32e1f42cc8f3903fea2790.zip
Added CMake-sanitizers scripts
Diffstat (limited to '3rdparty/sanitizers-cmake/tests')
-rw-r--r--3rdparty/sanitizers-cmake/tests/CMakeLists.txt52
-rw-r--r--3rdparty/sanitizers-cmake/tests/asan_test.cpp39
2 files changed, 91 insertions, 0 deletions
diff --git a/3rdparty/sanitizers-cmake/tests/CMakeLists.txt b/3rdparty/sanitizers-cmake/tests/CMakeLists.txt
new file mode 100644
index 00000000..6ffb38fb
--- /dev/null
+++ b/3rdparty/sanitizers-cmake/tests/CMakeLists.txt
@@ -0,0 +1,52 @@
+# This file is part of CMake-sanitizers.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in all
+# copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+#
+#
+# Copyright (c)
+# 2013-2015 Matt Arsenault
+# 2015 RWTH Aachen University, Federal Republic of Germany
+#
+
+# Function to add testcases.
+function(add_testcase TESTNAME SOURCEFILES)
+ # remove ${TESTNAME} from ${ARGV} to use ${ARGV} as ${SOURCEFILES}
+ list(REMOVE_AT ARGV 0)
+
+ # add a new executable
+ add_executable(${TESTNAME} ${ARGV})
+ add_sanitizers(${TESTNAME})
+
+ # add a testcase for executable
+ add_test(${TESTNAME} ${TESTNAME})
+endfunction(add_testcase)
+
+
+
+#
+# search for sanitizers
+#
+find_package(Sanitizers)
+
+
+
+#
+# add testcases
+#
+add_testcase("asan_test_cpp" asan_test.cpp)
diff --git a/3rdparty/sanitizers-cmake/tests/asan_test.cpp b/3rdparty/sanitizers-cmake/tests/asan_test.cpp
new file mode 100644
index 00000000..4b276ded
--- /dev/null
+++ b/3rdparty/sanitizers-cmake/tests/asan_test.cpp
@@ -0,0 +1,39 @@
+/* This file is part of CMake-sanitizers.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in
+ * all copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ *
+ *
+ * Copyright (c)
+ * 2013-2015 Matt Arsenault
+ * 2015 RWTH Aachen University, Federal Republic of Germany
+ */
+
+
+int
+main(int argc, char **argv)
+{
+ // Allocate a new array and delete it.
+ int *array = new int[argc];
+ delete[] array;
+
+ /* Access element of the deleted array. This will cause an memory error with
+ * address sanitizer.
+ */
+ return array[argc];
+}