aboutsummaryrefslogtreecommitdiffstats
path: root/3rdparty
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-05 13:49:40 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-05 13:49:40 +0200
commita20e90139ef27b35a7cc968674692ea40fef1c47 (patch)
tree1826543c00c11b1e92e0da7af016417c0810de79 /3rdparty
parent2f5b5369ba0a735e44ca425d5a22f911f73e6a35 (diff)
downloadnextpnr-a20e90139ef27b35a7cc968674692ea40fef1c47.tar.gz
nextpnr-a20e90139ef27b35a7cc968674692ea40fef1c47.tar.bz2
nextpnr-a20e90139ef27b35a7cc968674692ea40fef1c47.zip
disable few warnings for msvc
Diffstat (limited to '3rdparty')
-rw-r--r--3rdparty/QtPropertyBrowser/src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/3rdparty/QtPropertyBrowser/src/CMakeLists.txt b/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
index a312a10d..9d02d58d 100644
--- a/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
+++ b/3rdparty/QtPropertyBrowser/src/CMakeLists.txt
@@ -34,4 +34,8 @@ add_library(${TARGET_NAME} STATIC
${_QRC_SRCS}
)
+if (MSVC)
+ target_compile_options(${TARGET_NAME} PRIVATE /wd4457 /wd4718)
+endif()
+
target_link_libraries(${TARGET_NAME} Qt5::Widgets)