aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-13 08:34:58 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-13 08:34:58 +0200
commit0bf54951cf1cdb01c52be0ccceb94a5981cbdfff (patch)
treef3888c50ba38fa59f18d86aadea4fb52c19b4100
parent65bc2d3f3906791e6fc94e8548a556b0c9f03141 (diff)
downloadnextpnr-0bf54951cf1cdb01c52be0ccceb94a5981cbdfff.tar.gz
nextpnr-0bf54951cf1cdb01c52be0ccceb94a5981cbdfff.tar.bz2
nextpnr-0bf54951cf1cdb01c52be0ccceb94a5981cbdfff.zip
Compile on windows again
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83221f9d..74a94ae4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,10 @@ aux_source_directory(frontend/json/ JSON_PARSER_FILES)
set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES})
set(CMAKE_BUILD_TYPE Debug)
+if(MINGW)
+ add_definitions("-Wa,-mbig-obj")
+endif(MINGW)
+
foreach (family ${FAMILIES})
string(TOUPPER ${family} ufamily)
aux_source_directory(${family}/ ${ufamily}_FILES)