aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-03-31 10:11:09 +0100
committergatecat <gatecat@ds0.me>2021-03-31 10:11:09 +0100
commit3678eff5dc13b301f7841d2079ba265bbe3fac2b (patch)
tree2089f24d685263e5b8c8a47e29098c78f6940c0c
parent9259763599badeb7352b3179e7019582274a1b4b (diff)
downloadnextpnr-3678eff5dc13b301f7841d2079ba265bbe3fac2b.tar.gz
nextpnr-3678eff5dc13b301f7841d2079ba265bbe3fac2b.tar.bz2
nextpnr-3678eff5dc13b301f7841d2079ba265bbe3fac2b.zip
interchange: Fix nexus cmake review comments
Signed-off-by: gatecat <gatecat@ds0.me>
-rwxr-xr-x.github/ci/build_interchange.sh14
-rw-r--r--fpga_interchange/examples/chipdb.cmake2
-rw-r--r--fpga_interchange/examples/chipdb_nexus.cmake10
-rw-r--r--fpga_interchange/examples/devices/LIFCL-17/CMakeLists.txt1
4 files changed, 11 insertions, 16 deletions
diff --git a/.github/ci/build_interchange.sh b/.github/ci/build_interchange.sh
index 56fd3d57..dc839e93 100755
--- a/.github/ci/build_interchange.sh
+++ b/.github/ci/build_interchange.sh
@@ -35,19 +35,19 @@ function get_dependencies {
python3 -m pip install -r requirements.txt
popd
- ## Install RapidWright
- git clone https://github.com/Xilinx/RapidWright.git ${RAPIDWRIGHT_PATH}
- pushd ${RAPIDWRIGHT_PATH}
- make update_jars
- popd
-
- # Install prjoxide
if [ ${DEVICE} == "LIFCL-17" ]; then
+ # Install prjoxide
curl --proto '=https' -sSf https://sh.rustup.rs | sh -s -- -y
git clone --recursive https://github.com/gatecat/prjoxide.git
pushd prjoxide/libprjoxide
PATH=$PATH:$HOME/.cargo/bin cargo install --path prjoxide --all-features
popd
+ else
+ # Install RapidWright
+ git clone https://github.com/Xilinx/RapidWright.git ${RAPIDWRIGHT_PATH}
+ pushd ${RAPIDWRIGHT_PATH}
+ make update_jars
+ popd
fi
}
diff --git a/fpga_interchange/examples/chipdb.cmake b/fpga_interchange/examples/chipdb.cmake
index 100a69f4..a060576d 100644
--- a/fpga_interchange/examples/chipdb.cmake
+++ b/fpga_interchange/examples/chipdb.cmake
@@ -100,7 +100,7 @@ function(patch_device_with_prim_lib)
# )
# ~~~
#
- # Generates a patched device database starting from an input device
+ # Patches an input device with a primitive library from Yosys
#
# If output_target is specified, the variable named as the output_target
# parameter value is set to the generated output_device_file target.
diff --git a/fpga_interchange/examples/chipdb_nexus.cmake b/fpga_interchange/examples/chipdb_nexus.cmake
index 6ea613c5..4ea180c5 100644
--- a/fpga_interchange/examples/chipdb_nexus.cmake
+++ b/fpga_interchange/examples/chipdb_nexus.cmake
@@ -1,6 +1,6 @@
function(create_prjoxide_device_db)
# ~~~
- # create_rapidwright_device_db(
+ # create_prjoxide_device_db(
# device <common device>
# output_target <output device target>
# )
@@ -56,22 +56,19 @@ function(generate_nexus_device_db)
# ~~~
# generate_nexus_device_db(
# device <common device>
- # part <part>
# device_target <variable name for device target>
# )
# ~~~
#
# Generates a chipdb BBA file, starting from a Project Oxide device database.
# Patches applied:
- # - constraints patch
- # - luts patch
+ # - primitive library from Yosys
#
# Arguments:
# - device: common device name of a set of parts. E.g. LIFCL-17
- # - part: one among the parts available for a given device (currently ignored)
# - device_target: variable name that will hold the output device target for the parent scope
set(options)
- set(oneValueArgs device part device_target)
+ set(oneValueArgs device device_target)
set(multiValueArgs)
cmake_parse_arguments(
@@ -83,7 +80,6 @@ function(generate_nexus_device_db)
)
set(device ${generate_nexus_device_db_device})
- set(part ${generate_nexus_device_db_part})
set(device_target ${generate_nexus_device_db_device_target})
create_prjoxide_device_db(
diff --git a/fpga_interchange/examples/devices/LIFCL-17/CMakeLists.txt b/fpga_interchange/examples/devices/LIFCL-17/CMakeLists.txt
index 25848b7e..572ff200 100644
--- a/fpga_interchange/examples/devices/LIFCL-17/CMakeLists.txt
+++ b/fpga_interchange/examples/devices/LIFCL-17/CMakeLists.txt
@@ -1,6 +1,5 @@
generate_nexus_device_db(
device LIFCL-17
- part LIFCL-17-7SG72C
device_target lifcl17_target
)