aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-05-15 14:51:12 +0100
committergatecat <gatecat@ds0.me>2021-05-15 14:54:33 +0100
commit3bb94192d54bfcdbcd58dacd298aa6ff6d9b2bd2 (patch)
treef99379bfe78a5ec7ab0699f0df8a0e0b059094d0
parentb1e1492dac21f2c790540290e61fdd593126f50c (diff)
downloadnextpnr-3bb94192d54bfcdbcd58dacd298aa6ff6d9b2bd2.tar.gz
nextpnr-3bb94192d54bfcdbcd58dacd298aa6ff6d9b2bd2.tar.bz2
nextpnr-3bb94192d54bfcdbcd58dacd298aa6ff6d9b2bd2.zip
mistral: Tidying up
Signed-off-by: gatecat <gatecat@ds0.me>
-rw-r--r--common/archcheck.cc2
-rw-r--r--common/router2.cc3
-rw-r--r--mistral/arch.cc2
-rw-r--r--mistral/arch.h2
-rw-r--r--mistral/archdefs.h2
-rw-r--r--mistral/base_bitstream.cc2
-rw-r--r--mistral/constids.inc2
-rw-r--r--mistral/io.cc2
-rw-r--r--mistral/lab.cc2
-rw-r--r--mistral/pack.cc2
-rw-r--r--mistral/pins.cc2
-rw-r--r--mistral/qsf.cc2
12 files changed, 13 insertions, 12 deletions
diff --git a/common/archcheck.cc b/common/archcheck.cc
index 80d8ef58..f46db95c 100644
--- a/common/archcheck.cc
+++ b/common/archcheck.cc
@@ -28,7 +28,7 @@
USING_NEXTPNR_NAMESPACE
-#ifndef ARCH_CYCLONEV
+#ifndef ARCH_MISTRAL
// The LRU cache to reduce memory usage during the connectivity check relies on getPips() having some spacial locality,
// which the current CycloneV arch impl doesn't have. This may be fixed in the future, though.
#define USING_LRU_CACHE
diff --git a/common/router2.cc b/common/router2.cc
index d189cd68..ebd4e390 100644
--- a/common/router2.cc
+++ b/common/router2.cc
@@ -902,7 +902,8 @@ struct Router2
if ((net_data.fail_count % 3) == 0) {
// Every three times a net fails to route, expand the bounding box to increase the search space
#ifndef ARCH_MISTRAL
- // This patch seems to make thing worse for CycloneV, as it slows down the resolution of TD congestion, disable it
+ // This patch seems to make thing worse for CycloneV, as it slows down the resolution of TD congestion,
+ // disable it
net_data.bb.x0 = std::max(net_data.bb.x0 - 1, 0);
net_data.bb.y0 = std::max(net_data.bb.y0 - 1, 0);
net_data.bb.x1 = std::min(net_data.bb.x1 + 1, ctx->getGridDimX());
diff --git a/mistral/arch.cc b/mistral/arch.cc
index dd5c3b9a..516d1de8 100644
--- a/mistral/arch.cc
+++ b/mistral/arch.cc
@@ -480,4 +480,4 @@ const std::vector<std::string> Arch::availablePlacers = {"sa",
const std::string Arch::defaultRouter = "router2";
const std::vector<std::string> Arch::availableRouters = {"router1", "router2"};
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/arch.h b/mistral/arch.h
index 1bb2395c..c7d369f1 100644
--- a/mistral/arch.h
+++ b/mistral/arch.h
@@ -543,4 +543,4 @@ struct Arch : BaseArch<ArchRanges>
NEXTPNR_NAMESPACE_END
-#endif \ No newline at end of file
+#endif
diff --git a/mistral/archdefs.h b/mistral/archdefs.h
index 181bc618..5fd02ad5 100644
--- a/mistral/archdefs.h
+++ b/mistral/archdefs.h
@@ -233,4 +233,4 @@ template <> struct hash<NEXTPNR_NAMESPACE_PREFIX PipId>
} // namespace std
-#endif \ No newline at end of file
+#endif
diff --git a/mistral/base_bitstream.cc b/mistral/base_bitstream.cc
index 759cdfeb..9fa74fb9 100644
--- a/mistral/base_bitstream.cc
+++ b/mistral/base_bitstream.cc
@@ -97,4 +97,4 @@ void Arch::init_base_bitstream()
}
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/constids.inc b/mistral/constids.inc
index 76d82a0b..4f7d3ecf 100644
--- a/mistral/constids.inc
+++ b/mistral/constids.inc
@@ -74,4 +74,4 @@ X(Y)
X(LOC)
-X(MISTRAL_CLKENA) \ No newline at end of file
+X(MISTRAL_CLKENA)
diff --git a/mistral/io.cc b/mistral/io.cc
index 00918317..3a72b001 100644
--- a/mistral/io.cc
+++ b/mistral/io.cc
@@ -58,4 +58,4 @@ BelId Arch::get_io_pin_bel(const CycloneV::pin_info_t *pin) const
return bel_by_block_idx(CycloneV::pos2x(pos), CycloneV::pos2y(pos), id_MISTRAL_IO, (pad >> 14));
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/lab.cc b/mistral/lab.cc
index a6512c9a..abd0fec3 100644
--- a/mistral/lab.cc
+++ b/mistral/lab.cc
@@ -966,4 +966,4 @@ uint64_t Arch::compute_lut_mask(uint32_t lab, uint8_t alm)
return mask;
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/pack.cc b/mistral/pack.cc
index e704160c..90fbfd78 100644
--- a/mistral/pack.cc
+++ b/mistral/pack.cc
@@ -362,4 +362,4 @@ bool Arch::pack()
return true;
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/pins.cc b/mistral/pins.cc
index d0ce642e..c3637115 100644
--- a/mistral/pins.cc
+++ b/mistral/pins.cc
@@ -64,4 +64,4 @@ CellPinStyle Arch::get_cell_pin_style(const CellInfo *cell, IdString port) const
return PINSTYLE_NONE;
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END
diff --git a/mistral/qsf.cc b/mistral/qsf.cc
index 0c95bf2e..9a128595 100644
--- a/mistral/qsf.cc
+++ b/mistral/qsf.cc
@@ -278,4 +278,4 @@ void Arch::read_qsf(std::istream &in)
QsfParser(buf, getCtx())();
}
-NEXTPNR_NAMESPACE_END \ No newline at end of file
+NEXTPNR_NAMESPACE_END