aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-02-26 08:06:07 +0000
committerGitHub <noreply@github.com>2021-02-26 08:06:07 +0000
commit49fae990636b5b562355ffafdce7bc168bd1daf4 (patch)
tree0ee9b864dd1b32aef11e81a8151c3d78cc95d72f
parentde107da5b3c66d329de0a0430a67ca843e27f3bd (diff)
parenta0af4d8768d58da0cbd8b6761f7ada6e3fbcf9c0 (diff)
downloadnextpnr-49fae990636b5b562355ffafdce7bc168bd1daf4.tar.gz
nextpnr-49fae990636b5b562355ffafdce7bc168bd1daf4.tar.bz2
nextpnr-49fae990636b5b562355ffafdce7bc168bd1daf4.zip
Merge pull request #601 from YosysHQ/no-default-Werror
cmake: Don't enable any -Werror flags without opt-in
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 05b0cce7..5c0537ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -107,7 +107,7 @@ if (MSVC)
set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /W4 /wd4100 /wd4244 /wd4125 /wd4800 /wd4456 /wd4458 /wd4305 /wd4459 /wd4121 /wd4996 /wd4127")
else()
# N.B. the -Wno-array-bounds is to work around a false positive in GCC 9
- set(WARN_FLAGS "-Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-array-bounds -Werror=sign-compare -Werror=return-type")
+ set(WARN_FLAGS "-Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-array-bounds")
if (WERROR)
set(WARN_FLAGS "${WARN_FLAGS} -Werror")
endif()