aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-04 12:23:25 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-04 12:23:55 +0200
commit6eaae6196cca762ed4e46f6f4011000e07e6577b (patch)
tree8de6cba6f8488c3bb3aa8b63b08c5204985fe4d7
parente0a851976f7bc51702bc6ba667f36749cd554ebb (diff)
downloadnextpnr-6eaae6196cca762ed4e46f6f4011000e07e6577b.tar.gz
nextpnr-6eaae6196cca762ed4e46f6f4011000e07e6577b.tar.bz2
nextpnr-6eaae6196cca762ed4e46f6f4011000e07e6577b.zip
Fixed debug msvc build and fixed inaccessible base
-rw-r--r--CMakeLists.txt4
-rw-r--r--common/nextpnr.h2
2 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 088d13e5..6485ebdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -128,8 +128,8 @@ if(MINGW)
endif(MINGW)
if (MSVC)
- set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /DNDEBUG /O2 /MT")
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /D_DEBUG /Od /MTd")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /DNDEBUG /O2 /MD")
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /D_DEBUG /Od /MDd")
endif()
foreach (family ${FAMILIES})
diff --git a/common/nextpnr.h b/common/nextpnr.h
index 1c7571cc..9d46b654 100644
--- a/common/nextpnr.h
+++ b/common/nextpnr.h
@@ -61,7 +61,7 @@
NEXTPNR_NAMESPACE_BEGIN
-class assertion_failure : std::runtime_error
+class assertion_failure : public std::runtime_error
{
public:
assertion_failure(std::string msg, std::string expr_str, std::string filename, int line);