aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-02-17 11:58:57 -0800
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-02-17 12:03:17 -0800
commit8ef5411f703da784cf0d0a6f829bae427602ef8c (patch)
tree633a5e8b20292b8c2330e4cc65954c6255f5877a
parentb3dcc9d507547713b49b3be7c2978b7d47e52111 (diff)
downloadnextpnr-8ef5411f703da784cf0d0a6f829bae427602ef8c.tar.gz
nextpnr-8ef5411f703da784cf0d0a6f829bae427602ef8c.tar.bz2
nextpnr-8ef5411f703da784cf0d0a6f829bae427602ef8c.zip
Add utility targets for getting plain text outputs.
Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
-rw-r--r--fpga_interchange/examples/template.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/fpga_interchange/examples/template.mk b/fpga_interchange/examples/template.mk
index 8bdded3f..819cdb1f 100644
--- a/fpga_interchange/examples/template.mk
+++ b/fpga_interchange/examples/template.mk
@@ -1,7 +1,7 @@
include ../common.mk
.DELETE_ON_ERROR:
-.PHONY: all debug clean
+.PHONY: all debug clean netlist_yaml phys_yaml
all: build/$(DESIGN).dcp
@@ -25,6 +25,8 @@ build/$(DESIGN)_netlist.yaml: build/$(DESIGN).netlist
build/$(DESIGN).netlist \
build/$(DESIGN)_netlist.yaml
+netlist_yaml: build/$(DESIGN)_netlist.yaml
+
build/$(DESIGN).phys: build/$(DESIGN).netlist
$(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \
@@ -42,6 +44,8 @@ build/$(DESIGN)_phys.yaml: build/$(DESIGN).phys
build/$(DESIGN).phys \
build/$(DESIGN)_phys.yaml
+phys_yaml: build/$(DESIGN)_phys.yaml
+
debug: build/$(DESIGN).netlist
gdb --args $(NEXTPNR_BIN) \
--chipdb $(BBA_PATH) \