aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-01-27 18:12:47 -0800
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-01-27 18:13:10 -0800
commita5472bc5c10aae2e39f78246b78b52b6ba2c2912 (patch)
tree89e7e36d6f6d320af310f779071392955b856900
parentdc46d84c35d695748fa46fa6f27cd02ed0b05e03 (diff)
downloadnextpnr-a5472bc5c10aae2e39f78246b78b52b6ba2c2912.tar.gz
nextpnr-a5472bc5c10aae2e39f78246b78b52b6ba2c2912.tar.bz2
nextpnr-a5472bc5c10aae2e39f78246b78b52b6ba2c2912.zip
Default to Release, but allow other modes (e.g. Debug, RelWithDebInfo).
Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 344db1fb..b6fddcf1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -193,7 +193,9 @@ aux_source_directory(3rdparty/json11 EXT_JSON11_FILES)
aux_source_directory(frontend/ FRONTEND_FILES)
set(COMMON_FILES ${COMMON_SRC_FILES} ${EXT_JSON11_FILES} ${JSON_PARSER_FILES} ${FRONTEND_FILES})
-set(CMAKE_BUILD_TYPE Release)
+if( NOT CMAKE_BUILD_TYPE )
+ set(CMAKE_BUILD_TYPE Release)
+endif()
if(CMAKE_CROSSCOMPILING)
set(BBA_IMPORT "IMPORTFILE-NOTFOUND" CACHE FILEPATH