aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shah <davey1576@gmail.com>2018-07-30 15:20:50 +0200
committerDavid Shah <davey1576@gmail.com>2018-07-30 15:20:50 +0200
commitb5f90d381481dc3658c408b162aa433e183f79f4 (patch)
tree95b36b5e404b714ffb5e47142242abd509c656e1
parent0db86b8619883c0cbaf36150c3622c9d78d82d12 (diff)
downloadnextpnr-b5f90d381481dc3658c408b162aa433e183f79f4.tar.gz
nextpnr-b5f90d381481dc3658c408b162aa433e183f79f4.tar.bz2
nextpnr-b5f90d381481dc3658c408b162aa433e183f79f4.zip
cmake: Remove nextpnrpy so modules
Signed-off-by: David Shah <davey1576@gmail.com>
-rw-r--r--CMakeLists.txt11
1 files changed, 1 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41bd4aab..4c222d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -182,12 +182,7 @@ foreach (family ${ARCH})
add_executable(nextpnr-${family} ${COMMON_FILES} ${${ufamily}_FILES})
install(TARGETS nextpnr-${family} RUNTIME DESTINATION bin)
target_compile_definitions(nextpnr-${family} PRIVATE MAIN_EXECUTABLE)
-
- if (BUILD_PYTHON)
- # Add the importable Python module target
- PYTHON_ADD_MODULE(nextpnrpy_${family} ${COMMON_FILES} ${${ufamily}_FILES})
- endif()
-
+
# Add any new per-architecture targets here
if (BUILD_TESTS)
aux_source_directory(tests/${family}/ ${ufamily}_TEST_FILES)
@@ -210,10 +205,6 @@ foreach (family ${ARCH})
set(family_targets ${family_targets} nextpnr-${family}-test)
endif()
- if (BUILD_PYTHON)
- set(family_targets ${family_targets} nextpnrpy_${family})
- endif()
-
# Include the family-specific CMakeFile
include(${family}/family.cmake)
foreach (target ${family_targets})