aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2020-06-24 17:57:24 +0000
committerwhitequark <whitequark@whitequark.org>2020-06-25 14:03:37 +0000
commitbf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca (patch)
treec804de40d0daf000e6c0d48f12c8ae76b7fe423a
parent1dc1164dce88fade762956c1067aeb97fa3c0f9a (diff)
downloadnextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.tar.gz
nextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.tar.bz2
nextpnr-bf8d4c428e3ff0fbb83f35ab436b4de74f0d8eca.zip
CMake: require at least version 3.5 (Ubuntu 16.04).
-rw-r--r--CMakeLists.txt3
-rw-r--r--bba/CMakeLists.txt2
-rw-r--r--ecp5/CMakeLists.txt2
-rw-r--r--ice40/CMakeLists.txt2
4 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d5b1dc9..07c5fb7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,4 @@
-# TODO: sensible minimum CMake version
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.5)
project(nextpnr CXX)
option(BUILD_GUI "Build GUI" ON)
diff --git a/bba/CMakeLists.txt b/bba/CMakeLists.txt
index 60c04b51..f2b7f887 100644
--- a/bba/CMakeLists.txt
+++ b/bba/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.5)
project(bba CXX)
find_package(Boost REQUIRED COMPONENTS
diff --git a/ecp5/CMakeLists.txt b/ecp5/CMakeLists.txt
index eaa33b6f..303208ed 100644
--- a/ecp5/CMakeLists.txt
+++ b/ecp5/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.5)
project(chipdb-ecp5 NONE)
set(ALL_ECP5_DEVICES 25k 45k 85k)
diff --git a/ice40/CMakeLists.txt b/ice40/CMakeLists.txt
index a003443c..1bf64905 100644
--- a/ice40/CMakeLists.txt
+++ b/ice40/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.3)
+cmake_minimum_required(VERSION 3.5)
project(chipdb-ice40 NONE)
set(ALL_ICE40_DEVICES 384 1k 5k u4k 8k)