aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shah <davey1576@gmail.com>2018-06-02 13:48:12 +0200
committerDavid Shah <davey1576@gmail.com>2018-06-02 13:48:28 +0200
commitefcf4412ee4e2f640234783c4a566528487f4639 (patch)
tree1a715e391791b7c8cfa733ae5d6218db2f833d45
parent363ddd0f3c6e1e2f9e5caf2851ffcacf32765437 (diff)
downloadnextpnr-efcf4412ee4e2f640234783c4a566528487f4639.tar.gz
nextpnr-efcf4412ee4e2f640234783c4a566528487f4639.tar.bz2
nextpnr-efcf4412ee4e2f640234783c4a566528487f4639.zip
Improve documentation in CMakeLists.txt
Signed-off-by: David Shah <davey1576@gmail.com>
-rw-r--r--CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 494353fd..a2857d71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,11 +1,12 @@
# TODO: sensible minimum CMake version
cmake_minimum_required(VERSION 3.3)
project(nextpnr)
-
+# List of families to build
set(FAMILIES dummy ice40)
set(CMAKE_CXX_STANDARD 11)
# set(CMAKE_CXX_FLAGS "-Wall -pedantic -Wextra -Werror")
set(CMAKE_DEFIN)
+# List of Boost libraries to include
set(boost_libs filesystem thread)
# TODO: sensible minimum Python version
find_package(PythonInterp 3.5 REQUIRED)
@@ -14,7 +15,9 @@ find_package(PythonLibs 3.5 REQUIRED)
find_package(Boost REQUIRED COMPONENTS ${boost_libs})
# Find Boost::Python of a suitable version in a cross-platform way
-
+# Some distributions (Arch) call it libboost_python3, others such as Ubuntu
+# call it libboost_python35. In the latter case we must consider all minor versions
+# Original source: https://github.com/BVLC/caffe/blob/master/cmake/Dependencies.cmake#L148
set(version ${PYTHONLIBS_VERSION_STRING})
STRING(REGEX REPLACE "[^0-9]" "" boost_py_version ${version})
@@ -46,12 +49,18 @@ aux_source_directory(common/ COMMON_FILES)
foreach (family ${FAMILIES})
string(TOUPPER ${family} ufamily)
aux_source_directory(${family}/ ${ufamily}_FILES)
+ # Add the CLI binary target
add_executable(nextpnr-${family} ${COMMON_FILES} ${${ufamily}_FILES})
- # TODO: also build an importable Python module
+ # Add the importable Python module target
PYTHON_ADD_MODULE(nextpnrpy_${family} ${COMMON_FILES} ${${ufamily}_FILES})
+ # Add any new per-architecture targets here
+
+ # Set ${family_targets} to the list of targets being build for this family
set(family_targets nextpnr-${family} nextpnrpy_${family})
+ # Include the family-specific CMakeFile
include(${family}/family.cmake)
foreach (target ${family_targets})
+ # Include family-specific source files to all family targets and set defines appropriately
target_include_directories(${target} PRIVATE ${family}/)
target_compile_definitions(${target} PRIVATE ARCH_${ufamily} ARCHNAME=${family})
target_link_libraries(${target} LINK_PUBLIC ${Boost_LIBRARIES} ${PYTHON_LIBRARIES})