aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorClifford Wolf <clifford@clifford.at>2018-06-23 16:20:31 +0200
committerClifford Wolf <clifford@clifford.at>2018-06-23 16:20:31 +0200
commitfe26ce447155c88f13be1846b36de013e91c13a4 (patch)
tree488c5f1d3e2c0d1b2b0ae514f223a655f226c58f
parent80fbf7e4eb1a3bba4895dd240248b5a3b5a49dbb (diff)
downloadnextpnr-fe26ce447155c88f13be1846b36de013e91c13a4.tar.gz
nextpnr-fe26ce447155c88f13be1846b36de013e91c13a4.tar.bz2
nextpnr-fe26ce447155c88f13be1846b36de013e91c13a4.zip
Move json parser from frontend/json/ to json/
Signed-off-by: Clifford Wolf <clifford@clifford.at>
-rw-r--r--CMakeLists.txt4
-rw-r--r--json/jsonparse.cc (renamed from frontend/json/jsonparse.cc)0
-rw-r--r--json/jsonparse.h (renamed from frontend/json/jsonparse.h)0
3 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d41fcbe..20b3e014 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,9 +100,9 @@ if (BUILD_PYTHON)
endif ()
endif()
-include_directories(common/ frontend/json ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
+include_directories(common/ json/ ${Boost_INCLUDE_DIRS} ${PYTHON_INCLUDE_DIRS})
aux_source_directory(common/ COMMON_SRC_FILES)
-aux_source_directory(frontend/json/ JSON_PARSER_FILES)
+aux_source_directory(json/ JSON_PARSER_FILES)
set(COMMON_FILES ${COMMON_SRC_FILES} ${JSON_PARSER_FILES})
set(CMAKE_BUILD_TYPE Release)
diff --git a/frontend/json/jsonparse.cc b/json/jsonparse.cc
index 463efdd2..463efdd2 100644
--- a/frontend/json/jsonparse.cc
+++ b/json/jsonparse.cc
diff --git a/frontend/json/jsonparse.h b/json/jsonparse.h
index fe71444f..fe71444f 100644
--- a/frontend/json/jsonparse.h
+++ b/json/jsonparse.h