aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSean Cross <sean@xobs.io>2019-10-18 16:19:30 +0800
committerSean Cross <sean@xobs.io>2019-10-18 16:19:30 +0800
commit0db8995e8143fd93930586f1126a833e64649008 (patch)
tree983bdd449394092962941a0ae77f8b29c050ec91 /CMakeLists.txt
parentc365dd1cabc3a4308ab9110534918623622c246b (diff)
downloadnextpnr-0db8995e8143fd93930586f1126a833e64649008.tar.gz
nextpnr-0db8995e8143fd93930586f1126a833e64649008.tar.bz2
nextpnr-0db8995e8143fd93930586f1126a833e64649008.zip
cmake: don't link libutil on windows
libutil is only required to be linked on Linux. Signed-off-by: Sean Cross <sean@xobs.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fc38c130..7bdff611 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,7 +276,7 @@ foreach (family ${ARCH})
if (BUILD_PYTHON)
target_link_libraries(${target} LINK_PUBLIC ${PYTHON_LIBRARIES})
if (STATIC_BUILD)
- target_link_libraries(${target} LINK_PUBLIC ${CMAKE_THREAD_LIBS_INIT} ${CMAKE_DL_LIBS} ${ZLIB_LIBRARIES} ${EXPAT_LIBRARIES} -lutil)
+ target_link_libraries(${target} LINK_PUBLIC ${CMAKE_THREAD_LIBS_INIT} ${CMAKE_DL_LIBS} ${ZLIB_LIBRARIES} ${EXPAT_LIBRARIES})
if(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Windows" AND MSVC)
else()