aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-29 13:42:00 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-29 13:42:28 +0200
commit1566e9afc37f384eed43f9b14a90447b8d8ee061 (patch)
tree82e681d22b5d0af2f99f05dc7574ba3b42ff6635 /CMakeLists.txt
parent3b354c2a51f9d13d1f7d4d1f8acad200f9733bee (diff)
downloadnextpnr-1566e9afc37f384eed43f9b14a90447b8d8ee061.tar.gz
nextpnr-1566e9afc37f384eed43f9b14a90447b8d8ee061.tar.bz2
nextpnr-1566e9afc37f384eed43f9b14a90447b8d8ee061.zip
python interpreter is mandatory in any case
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cc712e72..41bd4aab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,9 +58,9 @@ if (BUILD_GUI AND NOT BUILD_PYTHON)
message(FATAL_ERROR "GUI requires Python to build")
endif()
+find_package(PythonInterp 3.5 REQUIRED)
if (BUILD_PYTHON)
# TODO: sensible minimum Python version
- find_package(PythonInterp 3.5 REQUIRED)
find_package(PythonLibs 3.5 REQUIRED)
else()
add_definitions("-DNO_PYTHON")