aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGabriel L. Somlo <gsomlo@gmail.com>2019-08-21 10:49:23 -0400
committerGabriel L. Somlo <gsomlo@gmail.com>2019-08-21 10:57:43 -0400
commit2d66f8e6c979149ff5254b8cc61540617bf5c103 (patch)
tree0435625f345b62d5efef64207da90a7c46d51f02 /CMakeLists.txt
parenta6a4349bd6ec9531937944a45fc0807c63057221 (diff)
downloadnextpnr-2d66f8e6c979149ff5254b8cc61540617bf5c103.tar.gz
nextpnr-2d66f8e6c979149ff5254b8cc61540617bf5c103.tar.bz2
nextpnr-2d66f8e6c979149ff5254b8cc61540617bf5c103.zip
cmake: add python38 to list of versions searched for boost components
Also, factor out actual search code (identical across versions). Signed-off-by: Gabriel Somlo <gsomlo@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 7 insertions, 18 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f662dbe7..77745f95 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -161,24 +161,13 @@ if (BUILD_PYTHON)
endwhile ()
if (NOT Boost_PYTHON_FOUND)
- find_package(Boost QUIET COMPONENTS python3 ${boost_libs})
- if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )
- set(Boost_PYTHON_FOUND TRUE)
- endif ()
- endif ()
-
- if (NOT Boost_PYTHON_FOUND)
- find_package(Boost QUIET COMPONENTS python36 ${boost_libs})
- if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )
- set(Boost_PYTHON_FOUND TRUE)
- endif ()
- endif ()
-
- if (NOT Boost_PYTHON_FOUND)
- find_package(Boost QUIET COMPONENTS python37 ${boost_libs})
- if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )
- set(Boost_PYTHON_FOUND TRUE)
- endif ()
+ foreach (PyVer 3 36 37 38)
+ find_package(Boost QUIET COMPONENTS python${PyVer} ${boost_libs})
+ if ("${Boost_LIBRARIES}" MATCHES ".*(python|PYTHON).*" )
+ set(Boost_PYTHON_FOUND TRUE)
+ break()
+ endif ()
+ endforeach ()
endif ()
if (NOT Boost_PYTHON_FOUND)