aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPepijn de Vos <pepijndevos@gmail.com>2020-12-30 15:59:55 +0100
committerGitHub <noreply@github.com>2020-12-30 14:59:55 +0000
commit3611f549024ed8b6a0d714f25d10951351097745 (patch)
treeeeaf0672cb60498371d8f0cb0a955ab177cb28f0 /CMakeLists.txt
parent5e53a182921dad0e128186a1fe8766062c7cae61 (diff)
downloadnextpnr-3611f549024ed8b6a0d714f25d10951351097745.tar.gz
nextpnr-3611f549024ed8b6a0d714f25d10951351097745.tar.bz2
nextpnr-3611f549024ed8b6a0d714f25d10951351097745.zip
Gowin target (#542)
* load wires * add slice bels * add IOB * add aliases * local aliases * broken packing stuff * working packer * add constraints * pnr runs1111 * add timing info * constraints * more constraint stuff * add copyright * remove generic reference * remove parameters * remove generic python api * add newline to end of file * some small refactoring * warn on invalid constraints * don't error on missing cell * comment out debugging print * typo * avoid copy * faster empty idstring * remove intermediate variable * no more deadnames * fix cst warnings * increase ripup and epsilon a bit * take single device parameter * add info to readme * gui stubs * Revert 4d03b681a8634e978bd5af73c97665500047e055 * assign ff_used in assignArchInfo * decrease beta for better routability * try to fix CI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 289a83b1..344db1fb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,9 +66,9 @@ endif()
set(PROGRAM_PREFIX "" CACHE STRING "Name prefix for executables")
# List of families to build
-set(FAMILIES generic ice40 ecp5 nexus)
+set(FAMILIES generic ice40 ecp5 nexus gowin)
set(STABLE_FAMILIES generic ice40 ecp5)
-set(EXPERIMENTAL_FAMILIES nexus)
+set(EXPERIMENTAL_FAMILIES nexus gowin)
set(ARCH "" CACHE STRING "Architecture family for nextpnr build")
set_property(CACHE ARCH PROPERTY STRINGS ${FAMILIES})