aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-07-20 13:22:47 +0100
committergatecat <gatecat@ds0.me>2021-07-20 15:01:34 +0100
commit41eecd7ce2e2200e5f76da1974a86c6f35831d1b (patch)
tree24240ecb3313c17c931b9ffdfd70e80411e4b2e2 /CMakeLists.txt
parentf3be638ea9536511d329d3e1ad726e847916f122 (diff)
downloadnextpnr-41eecd7ce2e2200e5f76da1974a86c6f35831d1b.tar.gz
nextpnr-41eecd7ce2e2200e5f76da1974a86c6f35831d1b.tar.bz2
nextpnr-41eecd7ce2e2200e5f76da1974a86c6f35831d1b.zip
gui: Improve Fatal Error message
Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58b0fead..78c1caa1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -168,6 +168,11 @@ if (BUILD_GUI AND NOT BUILD_PYTHON)
message(FATAL_ERROR "GUI requires Python to build")
endif()
+if (BUILD_GUI)
+ # For higher quality backtraces
+ set(CMAKE_ENABLE_EXPORTS ON)
+endif()
+
find_package(PythonInterp 3.5 REQUIRED)
if (BUILD_PYTHON)
# TODO: sensible minimum Python version