aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2020-07-23 18:40:54 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2020-07-23 18:40:54 +0200
commit6bb457be69af2e27e48ebbd48e8c3a32e114b0f2 (patch)
treea5ad60e96650d92a94142d702b525759edf4f0a4 /CMakeLists.txt
parent8f2b707d026597018333ac60e707e5ab78c25a91 (diff)
downloadnextpnr-6bb457be69af2e27e48ebbd48e8c3a32e114b0f2.tar.gz
nextpnr-6bb457be69af2e27e48ebbd48e8c3a32e114b0f2.tar.bz2
nextpnr-6bb457be69af2e27e48ebbd48e8c3a32e114b0f2.zip
Needed by python lib itself for static
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9591c216..a7f7eefa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,11 @@ if (STATIC_BUILD)
else()
set(CMAKE_FIND_LIBRARY_SUFFIXES ".a" ".so")
set(link_param "-static")
+ if (BUILD_PYTHON)
+ find_package(ZLIB)
+ find_package(EXPAT)
+ find_package(Threads)
+ endif()
endif()
endif()