aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-03-18 14:02:07 -0700
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-03-18 14:02:07 -0700
commit76c6e1248c3550bf5dfc6191421225507dabe404 (patch)
tree40fc4e0c01d7efae1612d65ece022c4aa7efe0be /CMakeLists.txt
parentd5021e7ed5aa3f30e25125e2569a6a94bbe502c4 (diff)
downloadnextpnr-76c6e1248c3550bf5dfc6191421225507dabe404.tar.gz
nextpnr-76c6e1248c3550bf5dfc6191421225507dabe404.tar.bz2
nextpnr-76c6e1248c3550bf5dfc6191421225507dabe404.zip
Add option to link against "libprofiler".
Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 704815e3..e3c4472c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,7 @@ option(COVERAGE "Add code coverage info" OFF)
option(STATIC_BUILD "Create static build" OFF)
option(EXTERNAL_CHIPDB "Create build with pre-built chipdb binaries" OFF)
option(WERROR "pass -Werror to compiler (used for CI)" OFF)
+option(PROFILER "Link against libprofiler" OFF)
set(CMAKE_INTERPROCEDURAL_OPTIMIZATION TRUE)
@@ -238,6 +239,9 @@ if (USE_THREADS)
list(APPEND EXTRA_LIB_DEPS absl::flat_hash_map)
list(APPEND EXTRA_LIB_DEPS absl::flat_hash_set)
endif()
+if(PROFILER)
+ list(APPEND EXTRA_LIB_DEPS profiler)
+endif()
foreach (family ${ARCH})
message(STATUS "Configuring architecture: ${family}")