aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-07-04 12:06:03 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-07-04 12:08:16 +0200
commitb96727549ccd319f61d33982f678075880fad166 (patch)
tree6d7fc3bc0d200b2c336bec74b1855ca5c577afbf /CMakeLists.txt
parentc9d1bce85994756f196a6eb22926ba4acaf42aec (diff)
downloadnextpnr-b96727549ccd319f61d33982f678075880fad166.tar.gz
nextpnr-b96727549ccd319f61d33982f678075880fad166.tar.bz2
nextpnr-b96727549ccd319f61d33982f678075880fad166.zip
Building using MSVC works
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b8629aaf..088d13e5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,9 +126,10 @@ set(CMAKE_BUILD_TYPE Release)
if(MINGW)
add_definitions("-Wa,-mbig-obj")
endif(MINGW)
+
if (MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj")
- set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /MTd")
+ set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} /DNDEBUG /O2 /MT")
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} /D_DEBUG /Od /MTd")
endif()
foreach (family ${FAMILIES})