aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2023-03-17 09:27:36 +0100
committermyrtle <gatecat@ds0.me>2023-03-17 10:38:11 +0100
commite4fcd3740dd8a650922903db6e15f4eaff25b5ee (patch)
tree788ef589fcba0f4c95d02c900a060cd3b54d4215 /CMakeLists.txt
parent4111cc25d653bde9fbda72b9cf9dc13a876e214a (diff)
downloadnextpnr-e4fcd3740dd8a650922903db6e15f4eaff25b5ee.tar.gz
nextpnr-e4fcd3740dd8a650922903db6e15f4eaff25b5ee.tar.bz2
nextpnr-e4fcd3740dd8a650922903db6e15f4eaff25b5ee.zip
cmake: Make HeAP placer always-enabled
Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f48a894c..4018cc3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,6 @@ check_ipo_supported(RESULT ipo_supported)
option(BUILD_GUI "Build GUI" OFF)
option(BUILD_PYTHON "Build Python Integration" ON)
option(BUILD_TESTS "Build tests" OFF)
-option(BUILD_HEAP "Build HeAP analytic placer" ON)
option(USE_OPENMP "Use OpenMP to accelerate analytic placer" OFF)
option(COVERAGE "Add code coverage info" OFF)
option(STATIC_BUILD "Create static build" OFF)
@@ -230,11 +229,8 @@ endif()
include_directories(common/kernel/ common/place/ common/route/ json/ frontend/ 3rdparty/json11/ ${PYBIND11_INCLUDE_DIR} ${Boost_INCLUDE_DIRS} ${Python3_INCLUDE_DIRS})
-if(BUILD_HEAP)
- find_package (Eigen3 REQUIRED NO_MODULE)
- link_libraries(Eigen3::Eigen)
- add_definitions(-DWITH_HEAP)
-endif()
+find_package (Eigen3 REQUIRED NO_MODULE)
+link_libraries(Eigen3::Eigen)
aux_source_directory(common/kernel/ KERNEL_SRC_FILES)
aux_source_directory(common/place/ PLACE_SRC_FILES)