aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-09-03 19:01:56 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-09-03 19:01:56 +0200
commite7fe046e571aa007fcb2e10af0a097b839bfef0c (patch)
tree41a92845d69ef1fc22d70f162bdb391dfb816927 /CMakeLists.txt
parentb8db177612d279bf95de54446d1deedeb833bdbd (diff)
downloadnextpnr-e7fe046e571aa007fcb2e10af0a097b839bfef0c.tar.gz
nextpnr-e7fe046e571aa007fcb2e10af0a097b839bfef0c.tar.bz2
nextpnr-e7fe046e571aa007fcb2e10af0a097b839bfef0c.zip
On macOS -static flag not needed just list of .a files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3796c453..0b02e73d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,9 @@ option(STATIC_BUILD "Create static build" OFF)
set(link_param "")
if (STATIC_BUILD)
set(Boost_USE_STATIC_LIBS ON)
- set(link_param "-static")
+ if(NOT ${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ set(link_param "-static")
+ endif()
endif()
# List of families to build