aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiodrag Milanovic <mmicko@gmail.com>2018-06-11 19:36:39 +0200
committerMiodrag Milanovic <mmicko@gmail.com>2018-06-11 21:30:22 +0200
commitf1cf449c099f30482f05d9a7c6209321050159d5 (patch)
tree1b9fb1138aff6e10a2a059cb947a6770a0075c62 /CMakeLists.txt
parenteb392f649ea544742849e50d920be677d09aa344 (diff)
downloadnextpnr-f1cf449c099f30482f05d9a7c6209321050159d5.tar.gz
nextpnr-f1cf449c099f30482f05d9a7c6209321050159d5.tar.bz2
nextpnr-f1cf449c099f30482f05d9a7c6209321050159d5.zip
compile QtPropertyBrowser
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6c6803d..83486603 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -93,7 +93,7 @@ foreach (family ${FAMILIES})
foreach (target ${family_targets})
# Include family-specific source files to all family targets and set defines appropriately
target_include_directories(${target} PRIVATE ${family}/)
- target_compile_definitions(${target} PRIVATE ARCH_${ufamily} ARCHNAME=${family})
+ target_compile_definitions(${target} PRIVATE ARCH_${ufamily} ARCHNAME=${family} -DQT_NO_KEYWORDS)
target_link_libraries(${target} LINK_PUBLIC ${Boost_LIBRARIES} ${PYTHON_LIBRARIES} ${GUI_LIBRARY_FILES})
endforeach (target)
endforeach (family)