aboutsummaryrefslogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorDavid Shah <davey1576@gmail.com>2018-06-02 13:57:08 +0200
committerDavid Shah <davey1576@gmail.com>2018-06-02 13:57:08 +0200
commit763fd56c2639c53f109245f8b029f24362d60d33 (patch)
treeafc066e3623a04b42943c03845430860dd15179e /README.md
parentefcf4412ee4e2f640234783c4a566528487f4639 (diff)
downloadnextpnr-763fd56c2639c53f109245f8b029f24362d60d33.tar.gz
nextpnr-763fd56c2639c53f109245f8b029f24362d60d33.tar.bz2
nextpnr-763fd56c2639c53f109245f8b029f24362d60d33.zip
Update README with CMake instructions
Signed-off-by: David Shah <davey1576@gmail.com>
Diffstat (limited to 'README.md')
-rw-r--r--README.md24
1 files changed, 23 insertions, 1 deletions
diff --git a/README.md b/README.md
index 652be226..2cfe0679 100644
--- a/README.md
+++ b/README.md
@@ -6,7 +6,29 @@ Supported Architectures
- iCE40
+Prequisites
+-----------
+
+ - CMake 3.3 or later
+ - Modern C++11 compiler, clang recommended
+ - Python 3.5 or later, including development libraries (`python3-dev` for Ubuntu)
+ - Boost libraries (`libboost-all-dev` for Ubuntu)
+ - Icestorm, with chipdbs installed in `/usr/local/share/icebox`
+
Building
--------
-Simply run `make`. \ No newline at end of file
+ - Use CMake to generate the Makefiles (only needs to be done when `CMakeLists.txt` changes)
+ - For a debug build, run `cmake -DCMAKE_BUILD_TYPE=Debug .`
+ - For a release build, run `cmake .`
+ - Use Make to run the build itself
+ - For all targets, just run `make`
+ - For just the iCE40 CLI binary, run `make nextpnr-ice40`
+ - For just the iCE40 Python module, run `make nextpnrpy_ice40`
+ - Using too many parallel jobs may lead to out-of-memory issues due to the significant memory needed to build the chipdbs
+
+Running
+--------
+
+ - To run the CLI binary, just run `./nextpnr-ice40`
+ - The Python module is called `nextpnrpy_ice40.so`. To test it, run `PYTHONPATH=. python3 python/python_test.py`