aboutsummaryrefslogtreecommitdiffstats
path: root/common/router2.cc
diff options
context:
space:
mode:
authorKeith Rothman <537074+litghost@users.noreply.github.com>2021-03-18 16:31:40 -0700
committerKeith Rothman <537074+litghost@users.noreply.github.com>2021-03-22 09:17:55 -0700
commite7d81913a48bffd970f7a92acc44eb36d9f996f7 (patch)
tree93704cb3edc4497651e23adfb7d6541eab1bb907 /common/router2.cc
parent53ed6979a964f3eaaabc0d97399eec9b4c3347f9 (diff)
downloadnextpnr-e7d81913a48bffd970f7a92acc44eb36d9f996f7.tar.gz
nextpnr-e7d81913a48bffd970f7a92acc44eb36d9f996f7.tar.bz2
nextpnr-e7d81913a48bffd970f7a92acc44eb36d9f996f7.zip
Add "checkPipAvailForNet" to Arch API.
This is important for distiguishing valid pseudo pips in the FPGA interchange arch. This also avoids a double or triple lookup of pip->net map. Signed-off-by: Keith Rothman <537074+litghost@users.noreply.github.com>
Diffstat (limited to 'common/router2.cc')
-rw-r--r--common/router2.cc20
1 files changed, 7 insertions, 13 deletions
diff --git a/common/router2.cc b/common/router2.cc
index 002a05a3..a233cdc5 100644
--- a/common/router2.cc
+++ b/common/router2.cc
@@ -588,7 +588,7 @@ struct Router2
bool did_something = false;
for (auto uh : ctx->getPipsUphill(flat_wires[cursor].w)) {
did_something = true;
- if (!ctx->checkPipAvail(uh) && ctx->getBoundPipNet(uh) != net)
+ if (!ctx->checkPipAvailForNet(uh, net))
continue;
if (cpip != PipId() && cpip != uh)
continue; // don't allow multiple pips driving a wire with a net
@@ -675,18 +675,12 @@ struct Router2
#else
if (is_bb && !hit_test_pip(ad.bb, ctx->getPipLocation(dh)))
continue;
- if (!ctx->checkPipAvail(dh)) {
- NetInfo *bound_net = ctx->getBoundPipNet(dh);
- if (bound_net != net) {
- if (bound_net != nullptr) {
- ROUTE_LOG_DBG("Skipping pip %s because it is bound to net '%s' not net '%s'\n",
- ctx->nameOfPip(dh), bound_net->name.c_str(ctx), net->name.c_str(ctx));
- } else {
- ROUTE_LOG_DBG("Skipping pip %s because it is reported not available\n", ctx->nameOfPip(dh));
- }
-
- continue;
- }
+ if (!ctx->checkPipAvailForNet(dh, net)) {
+ ROUTE_LOG_DBG("Skipping pip %s because it is bound to net '%s' not net '%s'\n", ctx->nameOfPip(dh),
+ ctx->getBoundPipNet(dh) != nullptr ? ctx->getBoundPipNet(dh)->name.c_str(ctx)
+ : "<not a net>",
+ net->name.c_str(ctx));
+ continue;
}
#endif
// Evaluate score of next wire