aboutsummaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorgatecat <gatecat@ds0.me>2021-05-15 09:51:05 +0100
committergatecat <gatecat@ds0.me>2021-05-15 14:54:33 +0100
commit511e46c40fb99b8b708e58b70fd9f4642222a67e (patch)
treec9a58c607bb60384ba9e212be7e1b155cd2f2cde /common
parente1aaf715c6065c728e1dfe250ef419d1fc405553 (diff)
downloadnextpnr-511e46c40fb99b8b708e58b70fd9f4642222a67e.tar.gz
nextpnr-511e46c40fb99b8b708e58b70fd9f4642222a67e.tar.bz2
nextpnr-511e46c40fb99b8b708e58b70fd9f4642222a67e.zip
router2: Reduce verbosity when debugging
Signed-off-by: gatecat <gatecat@ds0.me>
Diffstat (limited to 'common')
-rw-r--r--common/router2.cc2
1 files changed, 2 insertions, 0 deletions
diff --git a/common/router2.cc b/common/router2.cc
index 59763f86..cbed0f69 100644
--- a/common/router2.cc
+++ b/common/router2.cc
@@ -710,10 +710,12 @@ struct Router2
if (is_bb && !hit_test_pip(nd.bb, ctx->getPipLocation(dh)))
continue;
if (!ctx->checkPipAvailForNet(dh, net)) {
+#if 0
ROUTE_LOG_DBG("Skipping pip %s because it is bound to net '%s' not net '%s'\n", ctx->nameOfPip(dh),
ctx->getBoundPipNet(dh) != nullptr ? ctx->getBoundPipNet(dh)->name.c_str(ctx)
: "<not a net>",
net->name.c_str(ctx));
+#endif
continue;
}
#endif