aboutsummaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorSerge Bazanski <serge@bazanski.pl>2018-07-13 22:02:53 +0100
committerSerge Bazanski <serge@bazanski.pl>2018-07-13 22:03:57 +0100
commit7db6817a0b5afcf89e3c7eafc031a7eec59ee24e (patch)
treea7d35b2e2b34f95e86ff625f65c31ebb2e2b82ed /default.nix
parenta8c84e90a39c54174dd24b5b76bd17aed8311481 (diff)
downloadnextpnr-7db6817a0b5afcf89e3c7eafc031a7eec59ee24e.tar.gz
nextpnr-7db6817a0b5afcf89e3c7eafc031a7eec59ee24e.tar.bz2
nextpnr-7db6817a0b5afcf89e3c7eafc031a7eec59ee24e.zip
Add Nix(OS) support
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..664e3669
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,28 @@
+#
+# nextpnr -- Next Generation Place and Route
+#
+# Copyright (C) 2018 Serge Bazanski <q3k@symbioticeda.com>
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+#
+
+
+with import <nixpkgs> {};
+
+stdenv.mkDerivation rec {
+ name = "env";
+ env = buildEnv { name = name; paths = buildInputs; };
+ buildInputs = [
+ ( import ./nextpnr.nix )
+ ];
+}