aboutsummaryrefslogtreecommitdiffstats
path: root/ecp5/CMakeLists.txt
diff options
context:
space:
mode:
authorwhitequark <whitequark@whitequark.org>2020-07-01 20:22:21 +0000
committerwhitequark <whitequark@whitequark.org>2020-07-01 20:22:21 +0000
commitf6e30f22f4334c36a42622e8fddd9cd92d0fe543 (patch)
tree224e63f2e2bea8c0e78284b563057dd205d36557 /ecp5/CMakeLists.txt
parentc0901fb972e34d2d16b3ac0074a18542ba1c448d (diff)
downloadnextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.tar.gz
nextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.tar.bz2
nextpnr-f6e30f22f4334c36a42622e8fddd9cd92d0fe543.zip
CMake: fix path checks in chipdb build scripts.
`if(NOT DEFINED)` is not appropriate since a variable that contains `-NOTFOUND` still counts as `DEFINED`. This can cause issues if configuration fails, writes `-NOTFOUND` to the cache, and is then restarted.
Diffstat (limited to 'ecp5/CMakeLists.txt')
-rw-r--r--ecp5/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/ecp5/CMakeLists.txt b/ecp5/CMakeLists.txt
index 303208ed..5bb82f4c 100644
--- a/ecp5/CMakeLists.txt
+++ b/ecp5/CMakeLists.txt
@@ -25,7 +25,7 @@ else()
"Trellis install prefix")
message(STATUS "Trellis install prefix: ${TRELLIS_INSTALL_PREFIX}")
- if(NOT DEFINED TRELLIS_LIBDIR)
+ if(NOT TRELLIS_LIBDIR)
if(WIN32)
set(pytrellis_lib pytrellis.pyd)
else()
@@ -42,7 +42,7 @@ else()
endif()
message(STATUS "Trellis library directory: ${TRELLIS_LIBDIR}")
- if(NOT DEFINED TRELLIS_DATADIR)
+ if(NOT TRELLIS_DATADIR)
set(TRELLIS_DATADIR ${TRELLIS_INSTALL_PREFIX}/share/${TRELLIS_PROGRAM_PREFIX}trellis)
endif()
message(STATUS "Trellis data directory: ${TRELLIS_DATADIR}")