aboutsummaryrefslogtreecommitdiffstats
path: root/ecp5/CMakeLists.txt
diff options
context:
space:
mode:
authorYehowshua Immanuel <programmed4jesus@gmail.com>2020-11-17 17:53:46 -0500
committerGitHub <noreply@github.com>2020-11-17 17:53:46 -0500
commitfe8a0116299ca30e32a2ac7dcdb7d122bdd030f5 (patch)
treec698905bc3caecea61c5f80488e69fb7bb2bd5e4 /ecp5/CMakeLists.txt
parent93faa752f5aa1f41b552be94d0b3e732e893bbaf (diff)
downloadnextpnr-fe8a0116299ca30e32a2ac7dcdb7d122bdd030f5.tar.gz
nextpnr-fe8a0116299ca30e32a2ac7dcdb7d122bdd030f5.tar.bz2
nextpnr-fe8a0116299ca30e32a2ac7dcdb7d122bdd030f5.zip
Update CMakeLists.txt
I believe Prjtrellis has CMAKE define pytrellis as a shared module, not library. On MacOS, this makes a difference and NextPNR expected ``.dylib`` instead of ``.so``. Things still work on Linux.
Diffstat (limited to 'ecp5/CMakeLists.txt')
-rw-r--r--ecp5/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/ecp5/CMakeLists.txt b/ecp5/CMakeLists.txt
index ff6b2d20..bc34d51b 100644
--- a/ecp5/CMakeLists.txt
+++ b/ecp5/CMakeLists.txt
@@ -52,7 +52,7 @@ else()
if(WIN32)
set(pytrellis_lib pytrellis.pyd)
else()
- set(pytrellis_lib pytrellis${CMAKE_SHARED_LIBRARY_SUFFIX})
+ set(pytrellis_lib pytrellis${CMAKE_SHARED_MODULE_SUFFIX})
endif()
find_path(TRELLIS_LIBDIR ${pytrellis_lib}